We thought we’d seen the last of the problems with Nvidia’s 12VHPWR connector used for the RTX 40-series. However, it seems that the issues are not over, and the latest incident is different in a major way.

While the previous cases of melting connectors all affected cables supplied by Nvidia, things are different this time around. A Reddit user reported that their custom CableMod connector has melted, undermining previous theories about the root of the problem.

Humble-Brilliant-654 / Reddit

It’s been a while since the first report about Nvidia’s RTX 4090 and its melting cables. Each case was pretty similar — the connector melted when the GPU was running for a longer period of time. Sometimes, the card itself got damaged in the process. In response to the problem, Nvidia collected the affected cards for investigation.

The general consensus — echoed by Nvidia itself — was that the issue stems from the cable not being properly seated. The RTX 4090 itself is massive, as is the 16-pin power connector. As a result, some builders had to bend their connectors in order to install the GPU, and this caused the connection to be faulty. Many tech experts weighed in on the matter. Some suggested that only one of Nvidia’s cable manufacturers caused these issues, while others wrote it all off as a user error.

Ultimately, there haven’t been many cases of melting connectors, but each was loud enough that it still gave Nvidia a bit of a bad rep. The connector is present on other RTX 40-series cards too, such as the RTX 4080.

When the problem was first reported, CableMod was quick to jump on it and started sharing its plans for a custom 12VHPWR connector that was meant to solve the issue. The adapter plugs into the 16-pin port and can be installed at a 90-degree angle, which takes bending the cable out of the equation. In theory, that should be enough for the connector to be properly seated, but alas, it was not in this case.

Nvidia GeForce RTX 4090 is shown along with a hand holding the power cable adapter.

A Reddit user shared pictures of their custom CableMod 12VHPWR connector. According to the unlucky user, they hadbeen using it for two months when, all of a sudden, their computer started shutting down. This only happened during moments of high power consumption. The Redditor then checked the cable and found it to be completely melted. Fortunately, the GPU was not damaged.

While the user claims to have installed the card as intended (a click was heard when they plugged it in), some users in the comments insist that it may not have been pushed in all the way through. This shows that even CableMod’s custom connector may be unable to overcome how difficult these connectors are to handle in comparison to the previous generations of GPUs. It also highlights how important it is to double-and triple-check that yours is properly mated if you own one of Nvidia’s best graphics cards.

Fortunately for the user, CableMod was quick to respond and offer help. The company made it clear that it would even replace the GPU if that was necessary. The less happy news is that there seems to be no way to avoid the issue entirely, as even this custom connector failed to completely prevent it.

Today’s tech news, curated and condensed for your inbox


Check your inbox!

Please provide a valid email address to continue.

This email address is currently on file. If you are not receiving newsletters, please check your spam folder.

Sorry, an error occurred during subscription. Please try again later.

Editors’ Recommendations



LEAVE A REPLY

Please enter your comment!
Please enter your name here